Delphi Pages Forums

Delphi Pages Forums (http://www.delphipages.com/forum/index.php)
-   DB-Aware (http://www.delphipages.com/forum/forumdisplay.php?f=5)
-   -   Delphi Embarcadero don't work TDataSource.AutoEdit (http://www.delphipages.com/forum/showthread.php?t=217101)

Pedro.Fornet 02-12-2015 05:24 PM

Delphi Embarcadero don't work TDataSource.AutoEdit
 
Hi,

All versions of the Embarcadero Delphi does not work the TDataSource.autoedit.

when I set the TDataSource.autoedit = false and I press key DEL in DBEdit the field is changed and a error Dataset not in Edit or Insert mode when I try to exit the field.

is normal, i don't believe.

Tks

Pedro Luis

kolbasz 02-12-2015 05:50 PM

Hi,

If you want to prevent the user to accidentally edit the field set the ClientDataset.ReadOnly property to true.

regards,
kolbasz

Pedro.Fornet 02-12-2015 06:40 PM

Hi Kolbasz,

But, if I need to set ALL fields to Readonly, so I don't need set AutoEdit, is not correct, in the Delphi 7 it's work fine. It's a great bug.

you do not think?

Regards,

Pedro Luis

kolbasz 02-12-2015 06:46 PM

Well to be perfectly honest I never used the default TClientDataset/ TDataSource etc(at least not since the 90')...they are slow and buggy components. If you want somthing performant try IBOObjects, Zeos(I do not you your database server).

Pedro.Fornet 02-12-2015 08:29 PM

First i made a mistake with Dataset and Fields Readonly, i use the IBObjects, but i use the Tdatasource to linked they. always setting Autoedit = false to prevent edit since delphi 1.

But you gave me an alternative to the bug, or go back to Delphi 7 that works better for my previous projects.

Tks and Regards

Pedro luis

Norrit 02-13-2015 08:38 AM

This is a known bug
Easily to resolve, either run all updates of edit dbCtrls.pas as explained

http://qc.embarcadero.com/wc/qcmain.aspx?d=70959

Pedro.Fornet 02-20-2015 04:25 PM

But If it is a known bug, so why never fixed it.
This is not a only bug, are many, transparency on labels, sometimes (sometimes) lose fields. I click on the form he clicks a button, missing image of buttons, and so on.

Nobody had problems with embarcadero ?

Might be better to go back to the old and good Delphi 7.

But Tks Kolbasz and Norrit.

Pedro.Fornet 02-20-2015 04:39 PM

But If it is a known bug, so why never fixed it.
This is not a only bug, are many, transparency on labels, sometimes (sometimes) lose fields. I click on the form he clicks a button, missing image of buttons, and so on.

Nobody had problems with embarcadero.

Might be better to go back to the old and good Delphi 7.

But Tks Kolbasz and Norrit.


All times are GMT. The time now is 04:35 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.