Delphi Pages Forums  

Go Back   Delphi Pages Forums > Delphi Forum > .NET

Lost Password?

Reply
 
Thread Tools Display Modes
  #1  
Old 03-01-2002, 11:08 AM
Rodney Rodney is offline
Junior Member
 
Join Date: Mar 2002
Posts: 2
Default How I can prevent "Directory Busy" using Session.NetFileDir?

How can I prevent the "Directory is Busy" error when I open the application a second time? It occurs when I set the Session.NetDirFile property. For example:

procedure TformMain.FormCreate(Sender: TObject);
begin
Session.Active := False;
Session.NetFileDir := 'D:\';
Session.PrivateDir := 'D:\MasterDb';
try
Session.Active := True;
except
on EDBEngineError do
ShowMessage('Session error');
end;
try
tblCustomer.Active := True;
except
on EDBEngineError do
ShowMessage('Cannot open table');
end;
end;
Reply With Quote
  #2  
Old 03-01-2002, 11:11 AM
Ted On The NeT Ted On The NeT is offline
Senior Member
 
Join Date: Apr 2001
Posts: 2,182
Default RE: How I can prevent "Directory Busy" using Session.NetFileDir?

on the same machine? or multiple PC's (like in a network)

<tt>
Greetz,
::TeD On The NeT::

=[ QUESTIONS ]=========================================
don't forget to accept this reply if it helped you!
================================================== =====

=[ EXTRA INFO ]========================================
Location : Netherlands (GMT +01.00)
Languages : English, Dutch, German
Age : 25
ICQ : Be smart and figure out what my UIN is...
================================================== =====
</tt>
Reply With Quote
  #3  
Old 03-01-2002, 11:25 AM
Rodney Rodney is offline
Junior Member
 
Join Date: Mar 2002
Posts: 2
Default RE: How I can prevent "Directory Busy" using Session.NetFileDir?

On multiple PCs however the PC is essentially a dumb terminal since all of the software is on a single server.
Reply With Quote
  #4  
Old 03-01-2002, 11:32 AM
Ted On The NeT Ted On The NeT is offline
Senior Member
 
Join Date: Apr 2001
Posts: 2,182
Default RE: How I can prevent "Directory Busy" using Session.NetFileDir?

try setting the NetFileDir to a serverpath, and the PrivateDir to the local harddisk, like C:\. Don't share the private path on a network, this will give you the current error. give it a try.

<tt>
Greetz,
::TeD On The NeT::

=[ QUESTIONS ]=========================================
don't forget to accept this reply if it helped you!
================================================== =====

=[ EXTRA INFO ]========================================
Location : Netherlands (GMT +01.00)
Languages : English, Dutch, German
Age : 25
ICQ : Be smart and figure out what my UIN is...
================================================== =====
</tt>
Reply With Quote
  #5  
Old 03-02-2002, 02:20 AM
DarkHorse DarkHorse is offline
Senior Member
 
Join Date: Dec 2000
Posts: 1,636
Default RE: How I can prevent "Directory Busy" using Session.NetFileDir?

Hi,

Did u try setting the LOCAL SHARE property to TRUE in BDE Administrator.

Its in Configuration page -> SYSTEMS -> INIT.

Just have a try.

<cr>Pls. accept if it helped.</cr>

Thanx
Tomy.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.