Delphi Pages Forums  

Go Back   Delphi Pages Forums > Delphi Forum > General

Lost Password?

Reply
 
Thread Tools Display Modes
  #1  
Old 12-13-2006, 10:17 AM
rorscan rorscan is offline
Junior Member
 
Join Date: Jul 2006
Posts: 4
Default crash when installing component

When I try to install a new component in Delphi 2, Delphi crashes - no error messages, just a sudden shutdown of Delphi as the progress message says "compiling...". Re-opening D2, I see my same old VCL with no new component. All the rest of my D2 installation is working fine and my component source paths look correct. I'll appreciate all suggestions for correcting this so I can install components again. If possible, I'd like to avoid reinstalling D2 since my updates will be lost.

Phil
Reply With Quote
  #2  
Old 12-13-2006, 09:35 PM
digitiger digitiger is offline
Senior Member
 
Join Date: Jan 2001
Posts: 716
Default RE: crash when installing component

what componet are you trying to install?

If possible give its url, so someone can debug it and find the reason for you
Reply With Quote
  #3  
Old 12-15-2006, 07:43 PM
rorscan rorscan is offline
Junior Member
 
Join Date: Jul 2006
Posts: 4
Default RE: crash when installing component

Unfortunately, I've tried to install several different components and my D2 behaves the same with each, unceremoniously crashing. So I don't think it's the component - unless I got 3 bad ones in a row. Seems like it would have more to do with whatever Delphi does while trying to add a new component to the VCL. It can rebuild the same VCL with no problem but it can't add a new one. One clue might be that since I've moved my installation from computer to computer a number of times by copying files and folders, maybe I lost some needed file along the way - but can I know which without a dreaded re-install? As I said, all else works just fine.

Phil
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.